# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[-+ ]?[178]?[ ]?\d[ ]?\d[ ]?\d[ ]?\d[ ]?\d[ ]?\d[ ]?"
test_str = "'Собственник. Продаётся НОВАЯ 5-х комнатная квартира только после ремонта, всё новое в идеальном состоянии. Оплата только наличными, можно валютой. Отдельное место на подземном паркинге, автономное отопление, Стены – наружные, крупноформатный рядовой поризиванный камень. Внутренние перегородки — камень двойной поризованный. 5B0HИTЬ 76 OO 26. Или на Baйбep +7931ll78О93'"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.