package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[-+ ]?[178]?[ ]?\d[ ]?\d[ ]?\d[ ]?\d[ ]?\d[ ]?\d[ ]?`)
var str = `'Собственник. Продаётся НОВАЯ 5-х комнатная квартира только после ремонта, всё новое в идеальном состоянии. Оплата только наличными, можно валютой. Отдельное место на подземном паркинге, автономное отопление, Стены – наружные, крупноформатный рядовой поризиванный камень. Внутренние перегородки — камень двойной поризованный. 5B0HИTЬ 76 OO 26. Или на Baйбep +7931ll78О93'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}