#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)WebAPI login failure\. Reason: invalid credentials.*?((?:[0-9]{0,3}\.){3}[0-9]{0,3})"
Local $sString = "(W) 2024-04-28T17:30:57 - WebAPI login failure. Reason: invalid credentials, attempt count: 3, IP: ::ffff:192.168.2.167, username: fdasdf" & @CRLF & _
"" & @CRLF & _
"(W) 2024-04-28T17:30:57 - WebAPI login failure. Reason: other reason, attempt count: 3, IP: ::ffff:192.168.2.167, username: fdasdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")