$re = '/WebAPI login failure\. Reason: invalid credentials.*?((?:[0-9]{0,3}\.){3}[0-9]{0,3})/m';
$str = '(W) 2024-04-28T17:30:57 - WebAPI login failure. Reason: invalid credentials, attempt count: 3, IP: ::ffff:192.168.2.167, username: fdasdf
(W) 2024-04-28T17:30:57 - WebAPI login failure. Reason: other reason, attempt count: 3, IP: ::ffff:192.168.2.167, username: fdasdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);