const regex = /WebAPI login failure\. Reason: invalid credentials.*?((?:[0-9]{0,3}\.){3}[0-9]{0,3})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('WebAPI login failure\\. Reason: invalid credentials.*?((?:[0-9]{0,3}\\.){3}[0-9]{0,3})', 'gm')
const str = `(W) 2024-04-28T17:30:57 - WebAPI login failure. Reason: invalid credentials, attempt count: 3, IP: ::ffff:192.168.2.167, username: fdasdf
(W) 2024-04-28T17:30:57 - WebAPI login failure. Reason: other reason, attempt count: 3, IP: ::ffff:192.168.2.167, username: fdasdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}