using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*(?:\d+[a-zA-Z]+|[a-zA-Z]+\d+)\.html$)https?:\/\/.+$";
string input = @"https://www.example.com
https://www.example.com/demo
https://www.example.com/demo/abc
https://www.example.com/demo/abc/123.html
不匹配:
https://www.example.com/demo/abc/efg123.html
(可能含有数字)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}