re = /^(?!.*(?:\d+[a-zA-Z]+|[a-zA-Z]+\d+)\.html$)https?:\/\/.+$/m
str = 'https://www.example.com
https://www.example.com/demo
https://www.example.com/demo/abc
https://www.example.com/demo/abc/123.html
不匹配:
https://www.example.com/demo/abc/efg123.html
(可能含有数字)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end