const regex = /^(?!.*(?:\d+[a-zA-Z]+|[a-zA-Z]+\d+)\.html$)https?:\/\/.+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*(?:\\d+[a-zA-Z]+|[a-zA-Z]+\\d+)\\.html$)https?:\\\/\\\/.+$', 'gm')
const str = `https://www.example.com
https://www.example.com/demo
https://www.example.com/demo/abc
https://www.example.com/demo/abc/123.html
不匹配:
https://www.example.com/demo/abc/efg123.html
(可能含有数字)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}