import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\d{4}-\\d{2}-\\d{2})(.*)";
final String string = "2020-04-14 17:00:00\n"
+ "2012-01-01T17:52:27.8116975-12:00\n"
+ "2012-02-01T18:21:06\n"
+ "2012-03-01T00:00:00Z";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}