import re
regex = re.compile(r"(?:\d{4}-\d{2}-\d{2})(.*)", flags=re.MULTILINE)
test_str = ("2020-04-14 17:00:00\n"
"2012-01-01T17:52:27.8116975-12:00\n"
"2012-02-01T18:21:06\n"
"2012-03-01T00:00:00Z")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")