#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([<>=!]?)\s?((?:\d*\.)?\d+)\s?(.*)$"
Local $sString = "< 2 Mbps" & @CRLF & _
"> 2 Mbps" & @CRLF & _
"! 2 Mbps" & @CRLF & _
"<2 Mbps" & @CRLF & _
">2 Mbps" & @CRLF & _
"!2 Mbps" & @CRLF & _
"<2Mbps" & @CRLF & _
">2Mbps" & @CRLF & _
"!2Mbps" & @CRLF & _
"" & @CRLF & _
"< 1.5 Mbps" & @CRLF & _
"> 1.5 Mbps" & @CRLF & _
"! 1.5 Mbps" & @CRLF & _
"<1.5 Mbps" & @CRLF & _
">1.5 Mbps" & @CRLF & _
"!1.5 Mbps" & @CRLF & _
"<1.5Mbps" & @CRLF & _
">1.5Mbps" & @CRLF & _
"!1.5Mbps" & @CRLF & _
"" & @CRLF & _
"< 1.5 Mbps" & @CRLF & _
"< 1.5 M" & @CRLF & _
"< 1.5 Kbps" & @CRLF & _
"< 1.5 K" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"2 Mbps" & @CRLF & _
"2Mbps" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")