const regex = /^([<>=!]?)\s?((?:\d*\.)?\d+)\s?(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([<>=!]?)\\s?((?:\\d*\\.)?\\d+)\\s?(.*)$', 'gm')
const str = `< 2 Mbps
> 2 Mbps
! 2 Mbps
<2 Mbps
>2 Mbps
!2 Mbps
<2Mbps
>2Mbps
!2Mbps
< 1.5 Mbps
> 1.5 Mbps
! 1.5 Mbps
<1.5 Mbps
>1.5 Mbps
!1.5 Mbps
<1.5Mbps
>1.5Mbps
!1.5Mbps
< 1.5 Mbps
< 1.5 M
< 1.5 Kbps
< 1.5 K
2 Mbps
2Mbps
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}