#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)이름은 ([^이?고]+)이?고.*전화번호는 (\d{2,3}\S\d{3,4}\S\d{4}).*예약할 곳은 ([가-힣]+) 입니다\. 인원 수는 (\d+)명입니다\. 날짜는 (\d{4}-\d{2}-\d{2})"
Local $sString = "이름은 김철수이고 전화번호는 010-0000:0000, 예약할 곳은 월하마을 입니다. 인원 수는 9명입니다. 날짜는 2019-11-11"
Local $sSubst = "\5 \3 \1 외 \4 명 \2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)