import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "이름은 ([^이?고]+)이?고.*전화번호는 (\\d{2,3}\\S\\d{3,4}\\S\\d{4}).*예약할 곳은 ([가-힣]+) 입니다\\. 인원 수는 (\\d+)명입니다\\. 날짜는 (\\d{4}-\\d{2}-\\d{2})";
final String string = "이름은 김철수이고 전화번호는 010-0000:0000, 예약할 곳은 월하마을 입니다. 인원 수는 9명입니다. 날짜는 2019-11-11";
final String subst = "\\5 \\3 \\1 외 \\4 명 \\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}