# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"이름은 ([^이?고]+)이?고.*전화번호는 (\d{2,3}\S\d{3,4}\S\d{4}).*예약할 곳은 ([가-힣]+) 입니다\. 인원 수는 (\d+)명입니다\. 날짜는 (\d{4}-\d{2}-\d{2})"
test_str = "이름은 김철수이고 전화번호는 010-0000:0000, 예약할 곳은 월하마을 입니다. 인원 수는 9명입니다. 날짜는 2019-11-11"
subst = "\\5 \\3 \\1 외 \\4 명 \\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.