# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*\(\d{4}\)).+/$1/ig;t' <<< "EXAMPLE TEXT (2025) (TEXT 2) (TEXT 3)"