use strict;
my $str = 'EXAMPLE TEXT (2025) (TEXT 2) (TEXT 3)';
my $regex = qr/^(.*\(\d{4}\)).+/ip;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";