package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^(.*\(\d{4}\)).+`)
var str = `EXAMPLE TEXT (2025) (TEXT 2) (TEXT 3)`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}