#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^a-z\r\n]+):(.*(?:(?!\n[^a-z\r\n]+:)[\r\n].*)*)"
Local $sString = "OPERATOR: Some text with numbers, special characters and linebreaks." & @CRLF & _
"" & @CRLF & _
"NAME, COMPANY, POSITION: Some text with numbers, special characters and linebreaks." & @CRLF & _
"NAME: Some text with numbers, special characters and linebreaks." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"OPERATOR: Some text with numbers, special characters and linebreaks." & @CRLF & _
"" & @CRLF & _
"NAME, COMPANY, POSITION: Some text with numbers, special characters and linebreaks." & @CRLF & _
"NAME: Some text with numbers, special characters and linebreaks." & @CRLF & _
"test" & @CRLF & _
"" & @CRLF & _
"OPERATOR: Some text with numbers, special characters and linebreaks." & @CRLF & _
"" & @CRLF & _
"NAME, COMPANY, POSITION: Some text with numbers and :, special characters and linebreaks." & @CRLF & _
"NAME: Some text with numbers, special characters and linebreaks."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")