using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^a-z\r\n]+):(.*(?:(?!\n[^a-z\r\n]+:)[\r\n].*)*)";
string input = @"OPERATOR: Some text with numbers, special characters and linebreaks.
NAME, COMPANY, POSITION: Some text with numbers, special characters and linebreaks.
NAME: Some text with numbers, special characters and linebreaks.
OPERATOR: Some text with numbers, special characters and linebreaks.
NAME, COMPANY, POSITION: Some text with numbers, special characters and linebreaks.
NAME: Some text with numbers, special characters and linebreaks.
test
OPERATOR: Some text with numbers, special characters and linebreaks.
NAME, COMPANY, POSITION: Some text with numbers and :, special characters and linebreaks.
NAME: Some text with numbers, special characters and linebreaks.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}