import re
regex = re.compile(r"^([^a-z\r\n]+):(.*(?:(?!\n[^a-z\r\n]+:)[\r\n].*)*)", flags=re.MULTILINE)
test_str = ("OPERATOR: Some text with numbers, special characters and linebreaks.\n\n"
"NAME, COMPANY, POSITION: Some text with numbers, special characters and linebreaks.\n"
"NAME: Some text with numbers, special characters and linebreaks.\n\n\n\n"
"OPERATOR: Some text with numbers, special characters and linebreaks.\n\n"
"NAME, COMPANY, POSITION: Some text with numbers, special characters and linebreaks.\n"
"NAME: Some text with numbers, special characters and linebreaks.\n"
"test\n\n"
"OPERATOR: Some text with numbers, special characters and linebreaks.\n\n"
"NAME, COMPANY, POSITION: Some text with numbers and :, special characters and linebreaks.\n"
"NAME: Some text with numbers, special characters and linebreaks.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")