re = /^([^a-z\r\n]+):(.*(?:(?!\n[^a-z\r\n]+:)[\r\n].*)*)/m
str = 'OPERATOR: Some text with numbers, special characters and linebreaks.
NAME, COMPANY, POSITION: Some text with numbers, special characters and linebreaks.
NAME: Some text with numbers, special characters and linebreaks.
OPERATOR: Some text with numbers, special characters and linebreaks.
NAME, COMPANY, POSITION: Some text with numbers, special characters and linebreaks.
NAME: Some text with numbers, special characters and linebreaks.
test
OPERATOR: Some text with numbers, special characters and linebreaks.
NAME, COMPANY, POSITION: Some text with numbers and :, special characters and linebreaks.
NAME: Some text with numbers, special characters and linebreaks.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end