#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)We would like to acknowledge\b\s*(.*?)\b\s*for reporting this issue.$"
Local $sString = "An was addressed. We would like to acknowledge Martin Luther King of Union Inc for reporting this issue." & @CRLF & _
"An issue was addressed. We would like to acknowledge Jon Doe (facebook.com/JD) for reporting this issue."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")