// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)We would like to acknowledge\b\s*(.*?)\b\s*for reporting this issue.$").unwrap();
let string = "An was addressed. We would like to acknowledge Martin Luther King of Union Inc for reporting this issue.
An issue was addressed. We would like to acknowledge Jon Doe (facebook.com/JD) for reporting this issue.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}