package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)We would like to acknowledge\b\s*(.*?)\b\s*for reporting this issue.$`)
var str = `An was addressed. We would like to acknowledge Martin Luther King of Union Inc for reporting this issue.
An issue was addressed. We would like to acknowledge Jon Doe (facebook.com/JD) for reporting this issue.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}