const regex = /We would like to acknowledge\b\s*(.*?)\b\s*for reporting this issue.$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('We would like to acknowledge\\b\\s*(.*?)\\b\\s*for reporting this issue.$', 'gm')
const str = `An was addressed. We would like to acknowledge Martin Luther King of Union Inc for reporting this issue.
An issue was addressed. We would like to acknowledge Jon Doe (facebook.com/JD) for reporting this issue.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}