import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:[01][0-9]{0,2}|(?:2(?:5[0-5]{0,1}|[0-4][0-9]{0,1}|[6-9]{0,1}))|[3-9][0-9]{0,1})\\.){3}(?:[01][0-9]{0,2}|(?:2(?:5[0-5]{0,1}|[0-4][0-9]{0,1}|[6-9]{0,1}))|[3-9][0-9]{0,1})$";
final String string = "000.12.12.034\n"
+ "01.1.1.1\n"
+ "121.234.12.12\n"
+ "23.45.12.56\n"
+ "000.12.234.23.23\n"
+ "666.666.23.23\n"
+ ".213.123.23.32\n"
+ "23.45.22.32.\n"
+ "I.Am.not.an.ip\n"
+ "1.1.1.1\n"
+ "0.0.0.0\n"
+ "255.2.2.255\n"
+ "256.0.0.33\n"
+ "199.200.0.22\n"
+ "000\n"
+ "111\n"
+ "0\n"
+ "00\n"
+ "1\n"
+ "00\n"
+ "11\n"
+ "99\n"
+ "90\n"
+ "2\n"
+ "3\n"
+ "4\n"
+ "292\n"
+ "999\n"
+ "255\n"
+ "266\n"
+ "299\n"
+ "256\n"
+ "199\n"
+ "244\n\n"
+ "000.12.12.034\n"
+ "121.234.12.12\n"
+ "23.45.12.56\n"
+ "00.12.123.123123.123\n"
+ "122.23\n"
+ "Hello.IP\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}