# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?:[01][0-9]{0,2}|(?:2(?:5[0-5]{0,1}|[0-4][0-9]{0,1}|[6-9]{0,1}))|[3-9][0-9]{0,1})\.){3}(?:[01][0-9]{0,2}|(?:2(?:5[0-5]{0,1}|[0-4][0-9]{0,1}|[6-9]{0,1}))|[3-9][0-9]{0,1})$"
test_str = ("000.12.12.034\n"
"01.1.1.1\n"
"121.234.12.12\n"
"23.45.12.56\n"
"000.12.234.23.23\n"
"666.666.23.23\n"
".213.123.23.32\n"
"23.45.22.32.\n"
"I.Am.not.an.ip\n"
"1.1.1.1\n"
"0.0.0.0\n"
"255.2.2.255\n"
"256.0.0.33\n"
"199.200.0.22\n"
"000\n"
"111\n"
"0\n"
"00\n"
"1\n"
"00\n"
"11\n"
"99\n"
"90\n"
"2\n"
"3\n"
"4\n"
"292\n"
"999\n"
"255\n"
"266\n"
"299\n"
"256\n"
"199\n"
"244\n\n"
"000.12.12.034\n"
"121.234.12.12\n"
"23.45.12.56\n"
"00.12.123.123123.123\n"
"122.23\n"
"Hello.IP\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.