import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S";
final String string = "더 캄캄한 이곳에 shine like the stars\n"
+ "그 미소를 띠며 I'll kiss you goodbye\n\n"
+ "실컷 비웃어라 꼴좋으니까\n"
+ "이제 너희 1 2 3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}