import re
regex = re.compile(r"\S", flags=re.MULTILINE)
test_str = ("더 캄캄한 이곳에 shine like the stars\n"
"그 미소를 띠며 I'll kiss you goodbye\n\n"
"실컷 비웃어라 꼴좋으니까\n"
"이제 너희 1 2 3")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")