use strict;
my $str = '더 캄캄한 이곳에 shine like the stars
그 미소를 띠며 I\'ll kiss you goodbye
실컷 비웃어라 꼴좋으니까
이제 너희 1 2 3';
my $regex = qr/\S/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}