// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\S").unwrap();
let string = "더 캄캄한 이곳에 shine like the stars
그 미소를 띠며 I'll kiss you goodbye
실컷 비웃어라 꼴좋으니까
이제 너희 1 2 3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}