package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]+(\.[0-9]+)? ?(mph|miles per hour)\b`)
var str = `At over 233 mph, this boaty mc boatface is much faster than its competitor (clocking in at only 199 miles per hour).
The slowest train in the world (3mph) climbs the large hill steadily. While descending it can reach speeds of up to 3.9mph.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}