$re = '/[0-9]+(\.[0-9]+)? ?(mph|miles per hour)\b/m';
$str = 'At over 233 mph, this boaty mc boatface is much faster than its competitor (clocking in at only 199 miles per hour).
The slowest train in the world (3mph) climbs the large hill steadily. While descending it can reach speeds of up to 3.9mph.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);