// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[0-9]+(\.[0-9]+)? ?(mph|miles per hour)\b").unwrap();
let string = "At over 233 mph, this boaty mc boatface is much faster than its competitor (clocking in at only 199 miles per hour).
The slowest train in the world (3mph) climbs the large hill steadily. While descending it can reach speeds of up to 3.9mph.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}