import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]+(\\.[0-9]+)? ?(mph|miles per hour)\\b";
final String string = "At over 233 mph, this boaty mc boatface is much faster than its competitor (clocking in at only 199 miles per hour).\n"
+ "The slowest train in the world (3mph) climbs the large hill steadily. While descending it can reach speeds of up to 3.9mph.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}