using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\w{2}\+\d+\.\d{2}),((\w)\3\*\d),((\w)\5),(\w+)$";
string input = @"JK+6.00,PP*2,ZZ,GROUPO
DB+10.30,GG*5,PP,HELLO
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}