const regex = new RegExp('^(\\w{2}\\+\\d+\\.\\d{2}),((\\w)\\3\\*\\d),((\\w)\\5),(\\w+)$', 'gm')
const str = `JK+6.00,PP*2,ZZ,GROUPO
DB+10.30,GG*5,PP,HELLO
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}