import re
regex = re.compile(r"^(\w{2}\+\d+\.\d{2}),((\w)\3\*\d),((\w)\5),(\w+)$", flags=re.MULTILINE)
test_str = ("JK+6.00,PP*2,ZZ,GROUPO\n"
"DB+10.30,GG*5,PP,HELLO\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")