import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\w{2}\\+\\d+\\.\\d{2}),((\\w)\\3\\*\\d),((\\w)\\5),(\\w+)$";
final String string = "JK+6.00,PP*2,ZZ,GROUPO\n"
+ "DB+10.30,GG*5,PP,HELLO\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}