#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=\d*[a-z]\d*[a-z]\d*$)[a-z\d]{10}$"
Local $sString = "12345678ab" & @CRLF & _
"1234vv5678" & @CRLF & _
"ab12345678" & @CRLF & _
"" & @CRLF & _
"#2345678ab" & @CRLF & _
"1111111111" & @CRLF & _
"bbbbbbbbbb" & @CRLF & _
"1234567aaa" & @CRLF & _
"1aa111111a" & @CRLF & _
"aaaaaaaaa1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")