import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=\\d*[a-z]\\d*[a-z]\\d*$)[a-z\\d]{10}$";
final String string = "12345678ab\n"
+ "1234vv5678\n"
+ "ab12345678\n\n"
+ "#2345678ab\n"
+ "1111111111\n"
+ "bbbbbbbbbb\n"
+ "1234567aaa\n"
+ "1aa111111a\n"
+ "aaaaaaaaa1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}