using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=\d*[a-z]\d*[a-z]\d*$)[a-z\d]{10}$";
string input = @"12345678ab
1234vv5678
ab12345678
#2345678ab
1111111111
bbbbbbbbbb
1234567aaa
1aa111111a
aaaaaaaaa1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}