use strict;
my $str = '12345678ab
1234vv5678
ab12345678
#2345678ab
1111111111
bbbbbbbbbb
1234567aaa
1aa111111a
aaaaaaaaa1';
my $regex = qr/^(?=\d*[a-z]\d*[a-z]\d*$)[a-z\d]{10}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}