const regex = /^(?!.*\+\+) # não aceita dois "+" seguidos
[_A-Za-z0-9-\+]+(\.[_A-Za-z0-9-]+)* # username
@ # arroba
[A-Za-z0-9-]+(\.[A-Za-z0-9]+)*(\.[A-Za-z]{2,})$ # domínio/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\+\\+) # não aceita dois "+" seguidos
[_A-Za-z0-9-\\+]+(\\.[_A-Za-z0-9-]+)* # username
@ # arroba
[A-Za-z0-9-]+(\\.[A-Za-z0-9]+)*(\\.[A-Za-z]{2,})$ # domínio', 'gm')
const str = `a++@gmail.com
a+@gmail.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}