$re = '/^(?!.*\+\+) # não aceita dois "+" seguidos
[_A-Za-z0-9-\+]+(\.[_A-Za-z0-9-]+)* # username
@ # arroba
[A-Za-z0-9-]+(\.[A-Za-z0-9]+)*(\.[A-Za-z]{2,})$ # domínio/mx';
$str = 'a++@gmail.com
a+@gmail.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);