const regex = /\w+_\w+(?<![bfi]|dt)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w+_\\w+(?<![bfi]|dt)\\b', 'gm')
const str = `This is string_with_an_underscore a test text_i text_f text_b and ^test ending with text_dtfr text_dt
a_c_dt`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}