$re = '/\w+_\w+(?<![bfi]|dt)\b/m';
$str = 'This is string_with_an_underscore a test text_i text_f text_b and ^test ending with text_dtfr text_dt
a_c_dt';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);