import re
regex = re.compile(r"\w+_\w+(?<![bfi]|dt)\b", flags=re.MULTILINE)
test_str = ("This is string_with_an_underscore a test text_i text_f text_b and ^test ending with text_dtfr text_dt\n\n"
"a_c_dt")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")