re = /\w+_\w+(?<![bfi]|dt)\b/m
str = 'This is string_with_an_underscore a test text_i text_f text_b and ^test ending with text_dtfr text_dt
a_c_dt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end